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1 Introduction

1.1 What is ChangeIt! ?

ChangeIt! is a program to manage and edit the sounds of your synthesizer. It also includes a complete librarian as well as some tools that make the use of your synthesizer much easier.

To be more concrete you have the main functionality of ChangeIt! in the main-program and the synthesizer specific functions are covered in a specific synthesizer-DLL.

At the moment there are four DLL's available:

1. Support for the Roland JV/XP-family

2. Support for the Korg 01/W family.

3. Support for the Midi Sample Dump Standard (SDS)

4. Support for generic System-Exclusive-Dumps.

Since version 2.0 there is also the possibility to create panels with controllers that can send any kind of midi data.

Important:

Before you do any editing with ChangeIt! you should first make the correct settings (see 1.4 and 1.5) and then make a backup of the internal memory of your synth (see 2 and especially 2.1).

1.2 Copyright Note and Contact Details

ChangeIt! is Freeware. You can distribute ChangeIt! over the net as long as you make no changes to the files and distribute it for free. If you want to use ChangeIt! on a Shareware CD or any other way that you are paid for you have to ask me for permission.

If you find any bugs in ChangeIt! or in this documentation, have new ideas or simply want to tell me that you exist and have so much money that you want to send me a big stash of it, contact me:

Jürgen Moßgraber

Email:
mossgraber@iitb.fhg.de

Web:
http://aragon.iitb.fhg.de/moss/

1.3 System requirements

What do you need to run ChangeIt! ? A PC running Windows 95/98/ME or NT/2000 with a monitor resolution of at least 800x600 pixels.
1.4 Installation

Extract the files “ChangeItXXX.zip”, “Mfc42.zip”, “Msvcrt.zip”, “Oleaut32.zip“ and “Olepro32.zip” to a temporary directory and run SETUP.EXE. The last four files are only necessary if you do not have the files “MFC42.DLL”, “MSVCRT.DLL”, “OLEAUT32.DLL”
 and “OLEPRO32.DLL” already in your “WINDOWS \ SYSTEM“ directory.
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Figure 1: The Settings dialog

1.5 Getting started

After the installation has finished you can start the program by double-clicking on the ChangeIt!-icon on the desktop or in the start-menu. After the main window has appeared, you will first have to make your MIDI settings. Choose the menu “File” and then “Settings...”. The dialog in Figure 1 will appear.

The first tab allows to make some general settings:

Remote Midi Input
Select those input ports where you have connected a master keyboard or a midi faderbox. This is useful if the synthesizer you want to edit has no keyboard. You can see if ChangeIt! receives midi data from your keyboard or controller when the little bullet in the right part of the statusbar changes to green.
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Figure 2:Midi Input Notification

The option Basic Midi Controller is described in the sections 6, 10.1.5 and 10.2.2. If you enable Route Midi Controller to Synth all incoming midi controller messages (from the selected remote midi inputs) are routed to the active midi out device.

For the other two options refer to section 4.3.

For each installed synthesizer DLL there will be an additional tab. Please refer to chapter 10 for a description of those specific settings.

Click on the OK button to confirm your changes. Now you are ready to use ChangeIt!.

1.6 Exiting the program

If you want to exit the program choose “Exit” from the “File” menu. If you have not saved all of your changes in the opened banks or libraries before leaving the program you will be asked to do so.

2 Receiving data

Firstly, I strongly suggest that you make a backup of the user memory of your connected synths.  To do this select “Receive” from the MIDI menu, press “Ctrl + R” or press the  
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 - button.
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Figure 3: The Receive Dialog

A dialog appears in which you can enter a filename where the received data will be saved to. The filename is automatically set to the current date. If you like you can change it to any other name, for example type: “backup.syx”.

Now you must choose an entry from the “Automatic“- or the “Manual“-list:

· Manual: If you choose manual you can receive any kind of data, but you have to start it directly from your synth.

· Automatic: A specific request string is sent to the synthesizer which allows an automatic reception.
Note:
The generic module allows you to create your own request strings and connections. See section 10.3.1 for details.

When you are finished with your settings click on “Receive”.

2.1 Automatic reception

If you chose an entry from the “Automatic”-list a request is sent to your synth and the data you requested is automatically received. The bytes that are received are counted in the status dialog.

Important: Some synths (e.g. the Korg 01/W) send very large data packets so you will see no progress in the status dialog until the transmission has ended.
If you want to interrupt the receive process click on the stop button. When everything is received (this can take quite a while) a bank window (see chapter 4) will appear.

Note for Profis:
The file you chose to put the data in contains only the data you received (e.g. all patches), not a complete bank. If you now choose the save menu [image: image7.png]


, a complete bank (all the layers that the synthesizer DLL provides) that contains the received data will be written, leaving the unselected areas blank!
2.2 Manual receiving

If you chose an entry from the “Manual”-list wait till a dialog with the name “Status” appears. Follow the instructions that it contains:

· Start the bulk dump from your synth (refer to your synth’s manual).

· You will see the number of bytes that are received in the status dialog.

· When the whole dump is received click on the STOP button in the dialog.

If you want to interrupt the receive process click on the stop button. When everything has been received (this can take quite a while) a complete bank window will appear.

Note for Profis:
The file you chose to put the data in contains only the data you received (e.g. all patches), not a complete bank. If you now choose the save menu [image: image8.png]


, a complete bank (patches, performances and rhythms) that also contains the received data will be written, leaving the unselected areas blank!

2.3 Receive All

If you have more than one synth and want to store their data all at once choose “Receive All” from the MIDI menu or press “Ctrl + Shift  + R”.
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Figure 4: The Receive All Dialog

A dialog appears in which you can enter a directory where the received data will be saved to. In the chosen directory a new directory will be created which name is the current date.

Use the “>>” and “<< “ buttons to choose the data you want to receive. Each chosen data dump is stored to a file in the newly created directory. Click on “Receive” to start receiving data.

Important: Some synths (e.g. the Korg 01/W) send very large data packets so you will see no progress in the status dialog until the transmission has ended.
If you want to interrupt the receive process click on the stop button. When everything is received (this can take quite a while) a bank window (see chapter 4) for each data dump will appear.

3 Sending data

If you want to send the backed up data to your synth you first have to open it. Choose “Open...” in the “File” menu, press “Ctrl + O” or click on [image: image10.png]


.

Note: No matter what kind of data you have opened (such as only patches, one patch or three performances) a complete bank will be viewed.

To send the data back to your synth choose “Midi” and then “Send...”, press “Ctrl + D” or click on [image: image11.png]


.
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Figure 5: The Send Dialog

The dialog in Figure 5 will appear. As with Receive Data, you can select what you want to send: only a specific layer (Figure 5 shows the layers of the Korg 01/W family) or some of them. If you are done with the settings click on the “Send” button.

The bytes that are sent are counted in the status dialog. If you want to interrupt the send process click on the stop button.

Note:
If you send data with the generic synth module always the whole data will be sent. Also a different dialog appears which asks you to choose one of the generic setups
 to which the data will be sent.
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Figure 6 : Choose a setup for sending a generic data dump
4 Working with banks

What is a bank ? A bank comprises of the layers a specific synthesizer DLL provides. For example the Korg 01/W DLL provides the layers Program, Combination, Drum and Global. The items in a layer are refered to as “patches”. This can be a Roland JV Patch, Performance, Korg 01/W Program, etc.

4.1 Opening or creating a bank

To work with a bank you first have to open it or create a new one. If you want to know how to open an existing bank see chapter 2.3.
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Figure 7: A bank (for the Korg 01/W family)

To create a new empty bank choose “File” and then “New”, press “Ctrl + N” or click on [image: image15.png]


. A dialog appears where you can select bank or library, choose bank. After that you are asked for what synthsizer DLL you want to create a new bank.

A patch which is referenced from another layer (eg. a Korg 01/W Program is used in a Combination) is painted in a bold font.

4.2 Navigating in a bank

You can switch between the different layers of the bank by choosing one of them in the “View ( Layers” menu or click on the toolbar buttons: [image: image16.png]


. 

4.3 Changing the font size

If you want to get the bank window smaller or larger you can change the size of the font that is used: Choose “File” and then “Settings...”. A dialog appears where you can select the font size. Here you can also choose how many patches are shown in a column.

4.3.1 Selecting patches in a layer

You can select one or more patches by using the mouse or the keyboard. Selected patches are painted in blue, the active patch has a red border. 

If you select a patch it will be directly sent to the temp buffer of your synth, so that you can listen to it immediately. That also means that none of the user patches will be overwritten
. 

Selecting with the mouse

· If you want to select one patch, simply click on it with the left mouse button. 

· If you want to select some patches that are in sequence (e.g. patch 5 to 20), select the first patch then hold down the SHIFT key and select the last patch.

· To select patches that are not in order hold down the CTRL (this is STRG on a German keyboard) key and select the patches by clicking on them. You can also combine using the SHIFT and CTRL key.

Selecting with the keyboard

To select a patch with the keyboard, use the cursor keys, home key, page up / down keys or the end key. The active patch is not automatically sent to your synth until you press the RETURN key.

To select patches that are in order hold down the SHIFT key and use the navigation keys as described above.

4.4 The Undo and Redo function

The functions that are described in the following paragraphs can all be undone or redone by choosing “Edit” and then “Undo” or “Redo”. That means you have always the possibility of getting back your data if you made a mistake.

4.5 Rearranging patches

To rearrange the patches in a bank select the patches you want to move. Click on a selected patch with the left mouse button and hold it down. Drag the patches to the position you want. 

The position where the patches will be inserted are painted in grey (see Figure 8). Two things are important to note:

1. No patch will be overwritten. They are only rearranged.

If you rearrange patches that are required in another layer those links are also updated. This is a powerful feature: For example if you have a Roland JV/XP bank with a performance that uses patch 5 and then move this patch 5 to patch 20 your performance will normally use a wrong patch. ChangeIt! handles this for you and changes the information in the performance to the new position of the patch (20).
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Figure 8: Rearranging patches

4.6 Copying and pasting patches

To copy and paste patches ChangeIt! has a clipboard of it’s own called the Copybox (see Figure 9). To copy patches in the copybox select them and choose “Copy” from the “Edit” menu, press “Ctrl + C” or click on [image: image18.png]


.

To paste the patches to a bank (it can be any bank you have opened that matches the synthesizer DLL and the layer type
) select “Paste” from the “Edit” menu, press “Ctrl + V” or click on [image: image19.png]


. The Copybox like in Figure 9 will appear and you can select the patches you want to insert in the bank (you can select any patches you like by using the SHIFT and / or CTRL key like you do to select patches in a bank) and then click on the “Paste” button. The patches will overwrite the patches in the bank beginning with the active patch.

Patch type shows the layer type of which patches can be inserted into the active bank-layer.
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Figure 9: The Copybox

4.6.1 Further goodies of the Copybox

You can remove patches from the list in the Copybox by selecting them and clicking the “Remove” (Del) button. To clear the complete list use “Select All” (Ctrl + A) and then “ Remove ”. 

4.7 Drag and drop between banks

You do not have to use the Copybox to copy patches from one bank to another, you can use “Drag and Drop“ instead. Select some patches in a bank, hold down the left mouse key and move them to the destination bank. The patches that will be overwritten in the destination bank will be painted in grey (Once again the synthesizer DLL and layer type must match). Release the mouse button to complete the operation.

If you want to cancel the operation while dragging click the right mouse button and then release the left mouse button
. 

4.8 Initialising patches

If you want to initialise some patches, to create a new patch from scratch (for example), select them and choose “Init” from the “Edit” menu.

4.9 Writing patches to the synth

If you want to only write the active patch to your synth, instead of the complete bank, select “Write” from the “Edit” menu.

4.10 Further bank functions

4.10.1 The context sensitive menu

If you click the right mouse button in a bank a menu pops up that is related to the selected patches. Here you can choose the functions “Copy”, “Paste”, “Edit”, “Init” and “Write”. They are exactly the same as those described above. The “Edit” function will be described later.

4.10.2 Saving your work

You can save the complete bank by using “Save” in the “File” menu. To save the bank in a different file use “Save As”.

If you just want to save one or more specific layers, choose “File ( Save Layers”.
4.10.3 Printing the patch names

You can print the names of the patches of a layer on your printer. Choose “Print...” from the “File” menu, press “Ctrl + P” or click on [image: image21.png]


.

To see how the printed page will look like use “Print Preview”. To change your printer settings use “Print Setup...”.

4.10.4 Copy Sysex or Names To Clipboard

If you are a MIDI-System-Exclusive-Guru and want to take a look on all the bytes of a bank choose “Copy To Clipboard” from the “Edit” menu. ChangeIt! will copy the complete data of a bank to the Windows clipboard in formatted, readable way. You can insert the text in any text editor you own.

“Copy Names To Clipboard“ copies all the patch-names of the active layer to the clipboard.

4.10.5 Layer Dependencies

If you select “ Layer Dependencies” from the “View” menu a dialog appears which shows the dependencies between the active layer and other layers of the bank.

These dependencies also appear in a tooltip if you rest over a patch with the mouse.

4.10.6 Listening to Patches

If you want to listen to a patch use the “Piano Keyboard”. Choose “Piano Keyboard” from the “View” menu or click on [image: image22.png]


. A window with a piano keyboard appears. You can click on the keys with the mouse to play. As an alternative you can use the computer keyboard (C3 = “a”, C#3 = “w”, D3 = “s”, ...). By using the computer keyboard you can even play chords by pressing more than one key
.
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Figure 10:  The Piano Keyboard
You can also play MIDI files from the piano keyboard. Click on [image: image24.png]


 to choose a MIDI file.

Note:
The selected Midi Channel affects only the notes played on the Piano Keyboard not the MIDI file.

5 Working with Libraries

What is a library ? A library can contain some patches from different banks, different layers and even different synthesizer DLL’s. You can also add comments to the patches, sort them in categories and do different searches.

5.1 Opening or creating a library

To work with a library you first have to open it or create a new one. If you want to open an existing library do the same as if you want to open a bank but select a library file. ChangeIt! will then look something like Figure 11.
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Figure 11: A library with three patches

To create a new empty library choose “File” and then “New”, press “Ctrl + N” or click on [image: image26.png]


. A dialog appears where you can select bank or library, choose library.

5.2 Adding patches to a library

To add patches to a library you can use the Copybox or Drag and Drop them into the library. These functions are used like described in the bank section.

You can also Drag and Drop patches from a library to a bank.

5.3 Sorting patches

You can sort the patches by any of the criteria in the header of the window. These are: by Name, Date, Comment, Key 1, Key 2, ... or Key 8, Type. Simply click on one of them to sort the patches.

5.4 Selecting patches

To select a patch simply click on it. You can also use the CTRL and SHIFT key to select more than one patch. A selected patch will be sent to the temporary memory of your synth (like in a bank).

5.5 Deleting patches from the library

Select the patches that you want to delete from the library and choose “Delete” from the “Edit” menu or simply press the Delete button.

5.6 Changing patch properties

Select one or more patches and choose “Properties...” from the “Edit” menu. The dialog in Figure 12 will appear.

Here you can change the name of the patch, see the date and time when it was inserted in the library, assign up to 8 keys to it and add a comment.

To assign a key to a patch, first select a keygroup from the left list and then a key from the right list.

If you have selected more than one patch you can check the box at the bottom of the dialog. If you do so and press OK the settings for the keys and the comment you did for the patch that is actually displayed in this dialog will be used for all the other patches.
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Figure 12: Editing Patch Properties

5.6.1 Changing the keynames

If you want to have different names for the keygroups and keys select “Keys...” from the “Edit” menu. The dialog in Figure 13 will appear. You have 15 keygroups and 15 keys for each keygroup. Select the keygroup or the key which name you want to change and edit it in the editboxes above. The keys are related to all libraries.
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Figure 13: Changing the keynames 

5.7 Finding double patches

If you want to check if you have some patches in the library that are identical, you can choose “Find double patches” from the “Edit” menu. A list with the patches that are redundant is displayed - if the list is empty you have no double patches.
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Figure 14: The Find Dialog

5.8 Finding patches in a library

If you want to search for specific patches choose “Find...” from the “Edit” menu, press “Ctrl + F” or click on [image: image30.png]


. The dialog in Figure 14 will appear.

You can search for a patch name and up to four different keys. You can combine the search by different logical functions (AND, OR, ...). The example in the dialog should explain this a little bit.

If you click on the OK button only the patches that match the criteria that were selected in the find dialog will be shown in the bank the others are hidden. To show them all enter the find dialog once again and directly click OK.

6 Editing

To edit a patch from a bank select it and choose “Edit” from the “Edit...” menu, press “Ctrl + E” or click on [image: image31.png]


. You can also edit a patch from a library by selecting it and choosing “Edit” as described above. All the editing changes will only affect the temporary memory of your synth.

The dialog that appears contain the parameters from the synth and will not be explained here. Refer to your manual you got with the synth to know what they do. Having said that, there are some things that should be explained.

· In the patch mode are some pages that contain graphic envelopes. See Figure 15.
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Figure 15: A Graphic Envelope

You can change them by clicking on the blue boxes and moving the mouse (keep the mouse button held down). You can also have up to 10 presets for envelopes. You can edit those presets by clicking on the edit button beneath the envelopes or choosing “Envelope Presets...” from the “Edit” menu.

· You can change the active (selected) parameter with an external midi controller (e.g. the Peavey PC1600). The MIDI-controller which is used for that is set in the settings dialog on the global page: basic midi controller.

· When ever there is a key (like “C#4”) is to be inserted for a parameter you can use your midi keyboard. Press the button labelled Key beneath the parameter. A dialog appears which shows the keys that you are playing on your midi keyboard. If you have played the right key press OK.

· If you choose edit in the generic module the hex viewer shows up. It has some additions to a normal hex viewer. The F0 and F7 bytes and also the manufacturer ID are highlighted. If you move the mouse over the F0 bytes the number of bytes in the messages are shown at the bottom of the dialog. If you move the mouse over the manufacturer ID the name of the manufacturer is shown at the bottom of the dialog.
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Figure 16: The hex viewer of the generic module

7 Controller Panels

Controller panels can contain knobs, sliders and buttons which can send any kind of midi data to your midi gear. By using this feature you can create a lot of different remote controls.
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Figure 17: A controller panel

7.1 Creating controller panels

To create a new empty controller panel choose “File” and then “New”, press “Ctrl + N” or click on [image: image35.png]


. A dialog appears where you can select bank, library or controller, choose controller and OK. After that an empty controller panel appears.

7.2 Editing controller panels

7.2.1 Adding new controls

To add a new control choose “Edit” and then “Insert”, press “Ctrl + I” or click on [image: image36.png]


. Now the mouse cursor changes to a cross. Click on the panel to create a control with default dimensions or keep the mouse button pressed and drag the mouse to create a specific dimension. A dialog appears where you can select what kind of control you want to create and set its parameters. The parameters of the controls are described in the following paragraphs.

7.2.2 Group/Text

This is simply a control to show a text or a group rectangle with a title and does not send any midi data. Enter the text/title into text. Choose an option from border to set different borders around the text and enable Show Group Frame if you want to use the text for grouping other controls.

7.2.3 Button

This button control can send midi data when it is pressed and also when it is released. If you want to send midi data only when the button is clicked (mouse button pressed and released) enable Is Pushbutton. Enter a title for the button in caption. You may enter a longer description of the buttons functionality into tooltip.

If is Pushbutton is not enabled the button sends the On – value when it is pressed and the Off – value when it is depressed. The initial state of the button is set with Value.

Use the group Midi Message to define the type of message you want to send. The Message – field contains some letters which have a special meaning:

	K
	The midi channel on which the message is sent

	XX
	The value set by the control modulo 128

	YY
	The value set by the control divided by 128

	TT
	The selected midi controller (only Control Change)

	SS
	The checksum for the message (only System Exclusive)


Use the group Midi Output to set where the message is sent to. Choose the Port where your midi instrument is connected and the midi Channel on which it receives.

If you have a remote control which is able to send midi control changes you can also change the value of the control by midi. Set Remote to the preferred control change.

7.2.4 Choose

Use the Texts – field to enter the texts which should be presented to the user. Each text must be separated by a return. Enter also the matching Values for the midi messages. Select the initial Value.

Enter a description of the choose controls functionality into tooltip.

For a description of the Midi Message and Midi Output group see section 7.2.3.

7.2.5 Knob

Set the Minimum and the Maximum value of the knob. Value is the initial value of the knob. If you want to display a different value than that which is sent you can add an Offset.

Enter a description of the knobs functionality into tooltip.

For a description of the Midi Message and Midi Output group see section 7.2.3.

7.2.6 Slider

Select if the slider can be moved vertically or horizontally.

Set the Minimum and the Maximum value of the slider. Value is the initial value of the slider. If you want to display a different value than that which is sent you can add an Offset.

Enter a description of the sliders functionality into tooltip.

For a description of the Midi Message and Midi Output group see section 7.2.3.

7.3 Commands in design mode

Switch to the design mode by choosing “Edit” and then “Design”, press “Ctrl + G” or click on [image: image37.png]


.

Most commands may be familiar to you from design programs. All common editing commands are there like Copy, Paste, Delete and even Drag & Drop is possible.

Select controls by clicking on them (also use the Control key). If you double click on a control you can edit its parameters. If you selected some controls you can use the layout commands in the Layout – menu.

Use Tab Order to set the keyboard tabbing for the controls.

Use the menu item Info in the Edit menu to set and display general information about the control panel.

If you want to change all midi output ports and / or midi channels of a controller panel (maybe because you connected to your instrument to a different port) use the Set Output Ports command in the Edit – menu.

7.4 Using controller panels

If you find settings with a specific controller panel which you use more often you can use snapshots to store them. Use Add Snapshot (in the Edit – menu) to store a new snapshot and Edit Snapshots to rename and arrange them. You can recall a snapshot by choosing it from the drop down box in the toolbar.

You can reset all controllers to their initial values by using Reset from the Edit – menu.

8 Other program functions

8.1 Arranging windows

To arrange opened banks and libraries use the functions in the “Window“ menu. You can “Cascade“ and “Tile“ them and if some windows are minimised, you can use “Arrange Icons“.
If you want to gain more space to work you can hide the statusbar and the toolbar. Select “Toolbar“ and / or “Status Bar” in the “View” menu.

8.2 The “About ChangeIt!...” function

This menu in the “Help” menu shows some information about the program and also all loaded synth modules.

9 Uninstalling ChangeIt!

There is no uninstall program for ChangeIt! but you can do it yourself with a little effort:
1. Unregister the OCX controls from the registry that are used by ChangeIt!. To do this copy the file “REGSVR32.EXE”
 into your ChangeIt! directory. Open a dos box and enter the directory. Type “regsvr32 /u ChooseCtrl.ocx” in the dos box and press return. A message should appear that the control was successfully unregistered. Repeat this for “HexEdit.ocx”, “Knob.ocx”, “Envelope.ocx” and “TextRectangle.ocx”. Don’t delete the system files “MFC42.DLL”, “MSVCRT.DLL”, “OLEAUT32.DLL”
 and “OLEPRO32.DLL”. Other programs may require them !
2. Delete the files of ChangeIt!. Delete the directory which contains ChangeIt! with all it’s files. Make sure that there are no sysex files in it that you still need !

10 Specific Synthesizer-DLL’s

10.1 Support for the Roland JV/XP-family

This DLL supports the Roland JV-1080, JV-2080, XP-50, XP-60 and XP-80. It should work also with the XP-30 and the JV-1010 but I am not sure about this.

10.1.1 Settings

Choose the menu “File” and then “Settings...”. The dialog in Figure 18 will appear. Choose the tab labelled “Roland JV/XP”.
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Figure 18: The settings for the Roland JV/XP
Make the following settings:

Main section

· Input: Choose the MIDI input device where your synth is connected to.

· Output: Choose the MIDI output device where your synth is connected to.

· Device ID: Set the device ID of your synth. If you have never changed it, it will probably be 17 (see your synth handbook for details).

Which synth to use
Select the synthesizer you have connected to your PC.

Expansions

Select the expansion cards (if any) you have installed in the slots of your synthesizer. 

Note:
The selection of the expansion-boards is only used in the random function.

PCM Card

Select the PCM card if you have one.

Note:
If you want that the names of the waveforms and patches of the PCM card appear in the edit dialog you can set them in the file 8.pre in your ChangeIt! directory.

10.1.2 Bank Tool 1: Random Patches
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Figure 19: The Random Patches Dialog

A nice goodie is the “Random Patches...” function from the “Tools” menu. After selecting it the dialog in Figure 19 will appear.

The random operation produces new sounds based on the active bank. You can select the parameters for each Tone that should be changed by random. You can use the “Enable All” / “Disable All” buttons to check / uncheck them all.

After clicking OK the patches in the active bank will be overwritten with new random sounds.

You will get better results if you do not enable too many parameters at a time. If you select “Output” or “TVA” the sound will be often too soft to hear.

10.1.3 Bank Tool 2: Copy Effect Settings

If you select “Copy Effect Settings...” from the “Tools” menu a dialog appears where you can select a source patch or performance from which you want to copy the effect settings. Also select the destination patch or performance where it will be copied to. You can choose if you want to copy all effect settings or only those of the EFX, the Chorus or the Reverb.
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Figure 20: Copy to Patch

10.1.4 Bank Tool 3: Copy Rhythm Keys to a Patch

The “Copy Rhythm Keys to a Patch...“ function in the “Tools” menu addresses the problem of the JV / XP family that you can only select one drum kit in the performance mode. This is mainly a problem if you want to assign different effects to the drum sounds.

To solve it you can program up to four drum sounds in a patch and use it in the performance. To make life a little easier ChangeIt! helps you to automate this work.

Choose “Copy to Patch...” from the “Tools” menu. The dialog in Figure 20 appears. Select the rhythm that contains the drum sounds you want to put in a patch. Select the four sounds that you want to put in the patch and select the patch in the listbox below where the new sound should be written to. Then click OK.

The function will split the four sounds in four key zones so you can use it in a performance.

10.1.5 Bank Tool 4: The Virtual Synth

What is the Virtual Synth ? The Virtual Synth emulates an analog synthesizer with two oscilators, a filter with a ADSR envelope, a ADSR amplifier envelope and two LFO’s.

To activate the Virtual Synth choose “Virtual Synth...” from the “Tools” menu. The dialog in Figure 21 will appear.
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Figure 21: The Virtual Synthesizer

There are two types of controls used that both send changes directly to your synthesizer. The value of a knob is changed by pressing the left mouse button and moving the mouse button (keep the button held down). The other control is called choosebox. Click on it with the left mouse button and a menu with the possible values for this control will appear select the one you like.

The “Init“ button resets all controls to their initial values, such as when the dialog is opened.
The parameters should be easy to understand, but nevertheless here is a little description:

Osc A

Here you can set the wave that is used for oscillator A you can choose a Saw, Pulse or Triangle wave. Octave sets the pitch of the wave in octaves. Oscillator A is implemented by using Tone 1 of the JV/XP.

Osc B / Pitch EG

Here you can choose the second oscillator wave and have an additional Noise wave. Interval determines the pitch offset relative to the value set in Octave of osc A. Tune creates some fine pitch differences (like in the JV/XP).

Also there is a simple Pitch envelope that only effects osc B and has a Attack, Decay and Release parameter.

Mix

Determines the level between osc A and osc B.

Filter / Filter Envelope

Mode selects the filter type you have a 12db lowpass , a 24 lowpass (implemented by using Structure 2), a highpass and a bandpass filter. Also there is Cutoff and Resonance like in the JV/XP. Env determines how much the envelope effects the filtercutoff. The envelope has Attack, Decay, Sutain and Release. Velo->Dpth sets how much the keyboard velocity effects the depth of the filter envelope.

Amp Envelope

The Amplifier (TVA in the JV/XP) Envelope is the same as the filter envelope.

LFO 1 and 2

The two LFO’s have both a rate and depth. For the LFO wave you can select a sinus, saw or random wave that effects both LFO 1 and LFO 2. For the destination of LFO 1 you can select AB (which means the pitch of osc A and osc B), B (which means the pitch of osc B) or filter (which effects the filter).

For the destination of LFO 2 you can choose AB like above or Amp (which effects the amplifier envelope).

Control

MW determines what the modulation wheel should control. It can effect the filter (“Filter”), the pitch of oscillator B (“osc B”) or the depth of LFO 1 (L1 Dp).

Press determines what the aftertouch should control. It can effect the filter (“Filter”), the amplifier envelope (“Amp”) or the depth of LFO 1 (L1 Dp).

Voice selects if the synth is playable polyphonic or monophonic.
Glide determines if portamento is on or off and Glide Time sets the portamento time.

Controlling the Virtual Synth with an external midi-controller

You can control the parameters in the virtual synth dialog with a midi controller (e.g. the Peavey PC1600). 

The number of the basic midi controller is set in the settings dialog on the global page. What defines basic ? The basic midi controller always changes the selected (light-grey background) parameter. The next parameter is then controlled by  basic midi controller + 1 and so forth. That means if you set the basic midi controller to 6 for remote control, controller 7 changes the next parameter, etc. 

The best thing to use this is to select the first parameter in the first row, assign the sliders or knobs of your external controller to e.g. 6, 7, 8, 9, 10, 11, 12, 13. So you can control the first row. By pressing Alt + 1/2/3/4 you can jump between the four rows!

If this sounds difficult simply try it. It is fun!

10.1.6 Library Tool 1: Use Categories

This function will use the "Category" of a Roland JV-2080 patch as Key 1 for every Roland JV-2080 patch that is in the active library. This requires that the key-names of the library match those of the Roland categories. This is the case after the installation of ChangeIt!.

10.1.7 Things to know about the edit dialogs

· You can choose if the changes you make are directly sent to the synthesizer. If you want this, enable the checkbox which reads “Realtime”. If you want to send the changes all at once disable it and click on “Send Patch” to send the changes to your synthesizer.

· In every dialog is a button where you can copy tones or parts from one to another. In the patch mode you can even select the patch you want to copy it from.

· In patch mode, there are four checkboxes called “Multi Edit”. If they are all unchecked you can change every parameter separately for each tone. If you check some of them and change a value, the values of all the selected tones are changed.

10.2 Support for the Korg 01/W family

This DLL supports the Korg 01/W, 01/WFD, 01/RW. It should work also with the versions with the larger keyboards but I am not sure about this.

10.2.1 Settings

Choose the menu “File” and then “Settings...”. The dialog in Figure 22 will appear. Choose the tab labelled “Korg 01/W”.
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Figure 22: The settings for the Korg 01/W
Make the following settings:

Main section

· Input: Choose the MIDI input device where your synthesizer is connected to.

· Output: Choose the MIDI output device where your synthesizer is connected to.

If you own a PCM card for the 01/W you can enter the sample names of the PCM card in the file Korg01w.pcm which can be found in the ChangeIt! directory. The file that comes with ChangeIt! contains the names of the Orchestral card.

10.2.2 The Virtual Synth

What is the Virtual Synth ? The Virtual Synth emulates an analog synthesizer with two oscilators, a filter with a ADSR envelope, a ADSR amplifier envelope and two LFO’s.

To activate the Virtual Synth choose “Virtual Synth...” from the “Tools” menu. The dialog in Figure 21 will appear.

[image: image43.png]irtual Analog
e=—n & [ [
[ ] »

EECTTEN T —
TN NN NN N

Osc B Pitch EG

E—TTE—
0606060600606

Filter Lfo Pitch Lfo
«

00 .0 O .





Figure 23: The Virtual Synthesizer

There are two types of controls used that both send changes directly to your synthesizer. The value of a knob is changed by pressing the left mouse button and moving the mouse button (keep the button held down). The other control is called choosebox. Click on it with the left mouse button and a menu with the possible values for this control will appear select the one you like.

The “Init“ button resets all controls to their initial values, such as when the dialog is opened.
The parameters should be easy to understand, but nevertheless here is a little description:

Osc A

Here you can set the wave that is used for oscillator A you can choose a Saw, Pulse x% wave. Octave sets the pitch of the wave in octaves. 

Osc B / Pitch EG

Here you can choose the second oscillator wave and have an additional Noise wave. Interval determines the pitch offset relative to the value set in Octave of osc A. Tune creates some fine pitch differences.

Also there is a simple Pitch envelope that only effects osc B and has a Attack, Decay and Release parameter.

Mix

Determines the level between osc A and osc B.

Filter / Filter Envelope

Env determines how much the envelope effects the filtercutoff. The envelope has Attack, Decay, Sutain and Release. Velo->Dpth sets how much the keyboard velocity effects the depth of the filter envelope.

Amp Envelope

The Amplifier Envelope is the same as the filter envelope.

LFO 1 and 2

The two LFO’s have both a rate and depth. For the LFO wave you can select a triangle, saw, square or random wave that effects both LFO 1 and LFO 2. The destination of LFO 1 is the filter. The destination of LFO 2 is the pitch.

Control

MW determines what the modulation wheel should control. It can effect the filter (“Filter”) or the depth of LFO 1/2 (L1 Dp, L2 Dp).

Press determines what the aftertouch should control. It can effect the filter (“Filter”), the amplifier envelope (“Amp”) or the depth of LFO 1/2 (L1 Dp, L2 Dp).

Voice selects if the synthesizer is playable polyphonic or monophonic.
Controlling the Virtual Synth with an external midi-controller

You can control the parameters in the virtual synth dialog with a midi controller (e.g. the Peavey PC1600). 

The number of the basic midi controller is set in the settings dialog on the global page. What defines basic ? The basic midi controller always changes the selected (light-grey background) parameter. The next parameter is then controlled by  basic midi controller + 1 and so forth. That means if you set the basic midi controller to 6 for remote control, controller 7 changes the next parameter, etc. 

The best thing to use this is to select the first parameter in the first row, assign the sliders or knobs of your external controller to e.g. 6, 7, 8, 9, 10, 11, 12, 13. So you can control the first row. By pressing Alt + 1/2/3/4 you can jump between the four rows!

If this sounds difficult simply try it. It is fun!

10.3 Support for generic System-Exclusive-Dumps

You can use this module to backup the memory of any synthesizer, effect module or even your coffee machine if it supports MIDI.

10.3.1 Settings

Choose the menu “File” and then “Settings...”. The dialog in figure 22 will appear. Choose the tab labelled “Generic”. You can now create any number of settings for “Automatic”- or “Manual”-reception.

Click on “New” to create a new connection or “Delete” to remove one. Each setting has the following parameters:

Name

· Enter any name you like for this setting.

Connection

· Input: Choose the MIDI input device where your synthesizer is connected to.

· Output: Choose the MIDI output device where your synthesizer is connected to.

· Midi Block Size / Count: These settings depend on the synthesizer you use. Some of them send only a few large packets other a lot of small packets. The Korg 01/W for example matches the first category here you would make settings like 65536 / 2. Please refer to your synthesizer manual for this information.

· Delay: The computer waits for the milliseconds you define here between each sent midi block. This is for problems with slow synths.
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Figure 24: The settings for the generic module
Automatic Dump

· Request String: Enter a request string which will start an automatic "bulk dump" at your synthesizer. Please refer to your synthesizer manual for a description of those request strings.

Note:
If you leave this field empty this setting will show up in the “Manual”-list in the receive dialog. If it is filled out it appears in the “Automatic”-list.

· Size Of Dump: Enter the number of bytes which the dump contains.

Tip:
You can easily find out the number of bytes if you first leave this field empty, receive the data and then lookup the number of bytes from the size of the received file.

10.4 Support for the Midi Sample Dump Standard

This DLL supports the Midi Sample Dump Standard V1.0. You can use all sample frequency that your sampler supports, but only 16bit samples are supported at the moment.

10.4.1 Settings

Choose the menu “File” and then “Settings...”. Choose the tab labelled “ Midi Sample Dump Standard ”. The dialog in Figure 25 will appear.
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Figure 25: The settings for the Midi Sample Dump Standard

Make the following settings:

Main section

· Input: Choose the MIDI input device where your synthesizer is connected to.

· Output: Choose the MIDI output device where your synthesizer is connected to.

10.4.2 Receiving samples from the sampler

To receive a sample from your sampler use the manual mode described in section 2.2. After you have opened the bank you can choose “Export As Wave” from the tools menu to save the sample as a WAV-file.

10.4.3 Sending sample to the sampler

To send a sample back to your sampler create a new SDS bank and choose “Import Wave” from the tools menu. After that choose “Midi” and then “Send...”.

� If you notice after the installation that the Virtual Synth or the graphical envelopes are not working you have an old version of  “OLEAUT32.DLL”. Rerun the ChangeIt!-setup with the new version from my web-site.


� Generic setups are defined in the Generic-tab of the settings dialog.


� You can use this feature to quickly and easily listen to new patches you got maybe from the internet without sending it (and overwriting your user memory) to your synth. To quickly hear the next sound press the down key from the cursor keys and then the return key.


� This means simply that you e.g. can not copy a program from a Korg 01/W to a Roland JV/XP.


� This works at the moment only if you are over a bank or a library window.


� To use the keyboard the window of the Piano Keyboard has to be active.


� REGSVR32.EXE is not part of the ChangeIt! distribution. If you can’t find it on your harddisk or you can get it from Microsoft. Check out their WWW-page.


� If you notice after the installation that the Virtual Synth or the graphical envelopes are not working you have an old version of  “OLEAUT32.DLL”. Rerun the ChangeIt!-setup with the new version from my web-site.
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